Log in or register to post comments
Last post
cbshah's picture
Joined: 10/02/2011
Posts: 2
The file browser is disabled for security reasons
Hi
I am now able to manage the browse button in ckfinder but when I tried to browse image I am getting below message, how should I resolve this...


The file browser is disabled for security reasons. Please contact your system administrator and check the CKFinder configuration file.


Please guide me if any one passed through this issue.
mkesicki's picture
Joined: 28/10/2010
Posts: 348
Re: The file browser is disabled for security reasons
Hi,
please look at checkAuthentication function and comments to it in config.php file. This file is in main ckfinder directory.
avalonhill's picture
Joined: 03/02/2011
Posts: 2
Re: The file browser is disabled for security reasons
mkesicki wrote:Hi,
please look at checkAuthentication function and comments to it in config.php file. This file is in main ckfinder directory.



Have same issue. I look chekAuthentication and change to true, but this does not seem to be the best way to go. What would it be correct?

Thx
mkesicki's picture
Joined: 28/10/2010
Posts: 348
Re: The file browser is disabled for security reasons
You need some authorization method. It depends on your system .If you use some CMS you should join this method with your session. There is no 'one good ' method to do this. You can also return true and authenticate via browser (http authentication) .
avalonhill's picture
Joined: 03/02/2011
Posts: 2
Re: The file browser is disabled for security reasons
Thanks for the reply.

I'll try that, although do not know very well how to authenticate via browser
mkesicki's picture
Joined: 28/10/2010
Posts: 348
Re: The file browser is disabled for security reasons
If your server use apache and you have permissions, maybe try http://httpd.apache.org/docs/2.0/mod/mod_auth.html or look for something like this.
umesh2424's picture
Joined: 13/05/2011
Posts: 1
Re: The file browser is disabled for security reasons
Locate file named settings.php inside your drupal directory
(usually sites/default/settings.php) and set $cookie_domain variable to the
appropiate domain (remember to uncomment that line). If you don't do this,
CKFinder may show an information that the connector is disabled.

This is from ckeditor's readme.txt file. Do these changes and your problem will be solved.
wiktor's picture
Joined: 16/07/2007
Posts: 1658
Re: The file browser is disabled for security reasons
@umesh2424 - that's true, but note that you're referring to CKEditor module for Drupal (with built-in support for CKFinder, of course).

CKFinder is not only prepared to work with Drupal, so to not confuse other users, I just wanted to add that sites/default/settings.php, $cookie_domain etc. is something that only Drupal users are aware of.

Wiktor Walc
CTO, CKSource - http://cksource.com
--
Follow CKEditor on: Twitter | Facebook | Google+

skibumco's picture
Joined: 30/01/2012
Posts: 3
Re: The file browser is disabled for security reasons
umesh2424 wrote:Locate file named settings.php inside your drupal directory
(usually sites/default/settings.php) and set $cookie_domain variable to the
appropiate domain (remember to uncomment that line). If you don't do this,
CKFinder may show an information that the connector is disabled.

This is from ckeditor's readme.txt file. Do these changes and your problem will be solved.


There is no readme.txt using the Drupal 7 Module. I've also re-downloaded and have done a search for the file. Using the Mod Version of 7.x-1.6 w. Drupal: 7.10.

I fixed the issue by giving the permissions to a user and an anonymous user. It wont work until I give the permissions to the anonymous user. This seems real weird that you can't only give access to an admin or an authenticated user.

Before making this work and funtion properly:

Also in the config.php file in the ckfinder directory, everything is true except for the thumb settings:

$config['Thumbnails'] = Array(
'url' => $baseUrl . '_thumbs',
'directory' => $baseDir . '_thumbs',
'enabled' => true,
'directAccess' => false,
'maxWidth' => 100,
'maxHeight' => 100,
'bmpSupported' => false,
'quality' => 100);


In the filemanager.config.php file in the includes directory has no info in the code of CheckAuthentication, the only true or false call if found @ $GLOBALS['devel_shutdown'] = FALSE;

In the admin Module, I have set the File browser settings to a special path in my images folder: Example
Path to uploaded files:
/images/authors/
Absolute path to uploaded files
/images/authors/

Ive also tried taking out the / in all various ways in the beginning and ending.

When going to the settings.php file in the defaults directory, the only thing I see about cookies is the omitted line of: # $conf['omit_vary_cookie'] = TRUE;

Do I need to add this coolie code to the settings.php file?