Log in or register to post comments
Last post
slovak's picture
Joined: 20/02/2010
Posts: 11
_fck_bookmark="1"
Recently, I upgraded from CKEditor 3.1 to 3.4 and discovered a new to me 'feature'. I have a customized button that allows for specialized formatting, using a <pre> tag with attributes.

{ element : 'pre', attributes : { 'language' : 'php' } };

This worked previously, until the recent upgrade. Whenever I now markup some text using this button, I end up with extra <span> and _fck_bookmark within - I separated the lines below for clarity.

<pre language="php">
<span _fck_bookmark="1" style="display: none;"> </span>
marked up text
<span _fck_bookmark="1" style="display: none;"> </span>
</pre>

What is this span/bookmark, and how do I disable this behavior?

Many thanks!
slovak's picture
Joined: 20/02/2010
Posts: 11
Re: _fck_bookmark=&quot;1&quot;
Bump
slovak's picture
Joined: 20/02/2010
Posts: 11
Re: _fck_bookmark=&quot;1&quot;
Tried the newest version 3.4.1, and it seems the same behavior is repeated, except the content of span tags has changed slightly.

<span style="display: none;"> </span>
ladybug_3777's picture
Joined: 09/09/2010
Posts: 13
Re: _fck_bookmark=&quot;1&quot;
I'm having a similar problem. Created a post about it here: http://cksource.com/forums/viewtopic.php?f=11&t=21199

Have you found any more details as to the source of your issue with this span tag?
slovak's picture
Joined: 20/02/2010
Posts: 11
Re: _fck_bookmark=&quot;1&quot;
ladybug_3777 wrote:I'm having a similar problem. Created a post about it here: http://cksource.com/forums/viewtopic.php?f=11&t=21199

Have you found any more details as to the source of your issue with this span tag?


Seems to be directly related to adding a button as described in my initial post. Haven't gotten any other clues here or elsewhere.