n2ck0s's picture
Joined: 30/09/2007
Posts: 5
The file browser is disabled for security reasons.
The file browser is disabled for security reasons. Please contact your system administrator and check the CKFinder configuration file.


Has anyone else seen this error? I've opened ckfinder.config, but I am not sure if I should change anything. I am using .NET 2.0.

Tia,
Nikos.
wiktor's picture
Joined: 16/07/2007
Posts: 1669
Re: The file browser is disabled for security reasons.
Yes, that's why ckfinder.config exists for ;)
At least you should enable CKFinder:

enabled   = "false"

and configure base directory to your needs:
<BaseDirectory
url         = "/ckfinder/userfiles/"
serverPath   = ""
/>

Wiktor Walc
CTO, CKSource - http://cksource.com
--
Follow CKEditor on: Twitter | Facebook | Google+

n2ck0s's picture
Joined: 30/09/2007
Posts: 5
Re: The file browser is disabled for security reasons.
enabled   = "false"


I'm truly embarrassed :oops:. Thx for your time.
lf_web5's picture
Joined: 30/08/2008
Posts: 2
Re: The file browser is disabled for security reasons.
I'm having the same problem. But I am using PHP, someone help me?

ERROR: "The file browser is disabled for security reasons. Please contact your system administrator and check the CKFinder configuration file."

My config.php:

$baseUrl = '/userfiles/';

:arrow: Tank's
webdude's picture
Joined: 20/08/2008
Posts: 5
Re: The file browser is disabled for security reasons.
You need to read thru CK Finders Config file thouroughly
and enable it and PROTECT it
you can read my post here on how we protected our ck finder here
http://www.fckeditor.net/forums/viewtopic.php?f=10&t=10714

Always read the config and follow it...
Integration of CK Finder with FCK is easy
protecting the file browser is a necessary step and should be taken with care to do it properly

WebDude
sekarbright's picture
Joined: 13/08/2010
Posts: 1
Re: The file browser is disabled for security reasons.
i am using javascript integration :

i am including 2 files below:
ckeditor/ckeditor.js
ckfinder/ckfinder.js

Code like:

var editor = CKEDITOR.replace( 'editor_kama' );
editor.setData( '<p>Just click the <b>Image</b> or <b>Link</b> button, and then <b>&quot;Browse Server&quot;</b>.</p>' );
CKFinder.setupCKEditor( editor, 'ckfinder/' ) ;



When i browse server the same error comes..

"The file browser is disabled for security reasons. Please contact your system administrator and check the CKFinder configuration file"

Where to change the settings..
wiktor's picture
Joined: 16/07/2007
Posts: 1669
Re: The file browser is disabled for security reasons.
Check config.php / config.asp / config.cfm / config.ascx depending on which version you have downloaded and last but not least, take some time to read the documentation ;)

Wiktor Walc
CTO, CKSource - http://cksource.com
--
Follow CKEditor on: Twitter | Facebook | Google+

goodbyecouch's picture
Joined: 19/08/2010
Posts: 3
Re: The file browser is disabled for security reasons.
Hi - I have been through the documentation but still get the same message.

My config.php file is set to

function CheckAuthentication()
{
// WARNING : DO NOT simply return "true". By doing so, you are allowing
// "anyone" to upload and list the files in your server. You must implement
// some kind of session validation here. Even something very simple as...

return isset($_SESSION['IsAuthorized']) && $_SESSION['IsAuthorized'];

// ... where $_SESSION['IsAuthorized'] is set to "true" as soon as the
// user logs in your system. To be able to use session variables don't
// forget to add session_start() at the top of this file.

//return false;
}


$config['RoleSessionVar'] = 'CKFinder_UserRole';
session_start();

and I have

userfiles =777

I see nowhere one can say enabled = true as on an earlier post in this thread.

Thanks
goodbyecouch's picture
Joined: 19/08/2010
Posts: 3
Re: The file browser is disabled for security reasons.
Hi - okay fixed by a friend of mine

He found there was no no "IsAuthorized" variable on our site so temporarily have to set it to just

return true;

Now have to work out how to set a IsAuthorized variable to the site :>

Cheers
Chris
pugilist_arcane's picture
Joined: 05/04/2013
Posts: 1
in ur config.php file.  the

in ur config.php file.  the function checkAuthentication() is set to return false. change it to return true.  it worked for me

fayyazurrehman's picture
Joined: 16/02/2012
Posts: 2
asp.net c# : facing same error

I don't where the enable option is. I am seeing anything which says enabled = false

asp.net c# : facing same error 

 

The file browser is disabled for security reasons. Please contact your system administrator and check the CKFinder configuration file