Log in or register to post comments
Last post
alfonsoml's picture
Joined: 31/12/2006
Posts: 3749
Re: Problem with CKEditor changing my " marks to &quote
That problem is usually a setting in PHP/Apache.
garymgordon's picture
Joined: 06/11/2010
Posts: 11
Re: Problem with CKEditor changing my " marks to &quote
Well, I am working on a Windows 2008 server with IIS7. When I use WP Super Edit (as my WYSIWYG editor), I don't have this problem.

I'm presuming that something in CKEditor just isn't working properly.

And since PHP on Windows is normally not an issue at all, I'm just hoping someone might be able to find out what the problem is and correct it for use on Windows.

I really like the editor, but can't use it .. if it re-writes my code.

Gary
alfonsoml's picture
Joined: 31/12/2006
Posts: 3749
Re: Problem with CKEditor changing my " marks to &quote
You're right.
I don't know why it's done that way as double quotes are safe IMHO, I've created http://dev.ckeditor.com/ticket/6645
garymgordon's picture
Joined: 06/11/2010
Posts: 11
Re: Problem with CKEditor changing my " marks to &quote
I'm so sorry, but I'm confused.

I found the patch information at: http://dev.ckeditor.com/attachment/tick ... 1653.patch

But I don't know what to do with this. I don't know what I should edit, update, etc.

I apologize for my not being familiar with this, but if you can explain specifically .. what I need to do, and to what files, etc., that would help me greatly.

Thanks,
Gary
karnius's picture
Joined: 25/03/2010
Posts: 17
Re: Problem with CKEditor changing my " marks to &quote
Same problem here,

A hotfix new release would be great as this is really a regression...
alfonsoml's picture
Joined: 31/12/2006
Posts: 3749
Re: Problem with CKEditor changing my " marks to &quote
Sorry, if you're not sure about what to do after reading the docs, then it's better to wait until a new version is released.

And about this deserving a hotfix release, what was the previous version were it worked correctly?
It's important to know that because the proposed patch might be wrong.
garymgordon's picture
Joined: 06/11/2010
Posts: 11
Re: Problem with CKEditor changing my " marks to &quote
alfonsoml,

Do you know approximately when the new version, with the fix, will be released?

Do you think it's a matter of a day or so, a week or more, etc.??

I'm just anxious to be able to test it and I hope it works. :D

Thanks,
Gary
alfonsoml's picture
Joined: 31/12/2006
Posts: 3749
Re: Problem with CKEditor changing my " marks to &quote
http://dev.ckeditor.com/roadmap

Of course, any date is tentative and might slip due to not being ready for release.
garymgordon's picture
Joined: 06/11/2010
Posts: 11
Re: Problem with CKEditor changing my " marks to &quote
I just want to say again, that this is for CKEditor in my Wordpress website.

When I looked at CKEditor for Wordpress, I didn't see all the _Source folders, etc. But if I download CKEditor from the website (which is different from CKEditor for Wordpress), then I saw the _Source folders, etc.

So, this issus, just to repeat is in CKEditor in Wordpress.

Thanks, .. and I'll be looking forward to the next version.

I appreciate your help.

:-)
Gary
mikeg's picture
Joined: 20/11/2010
Posts: 5
Re: Problem with CKEditor changing my " marks to &quote
Same problem here - I just wasted three days (guess I'm not that clever...) trying to make caption work. I deactivated the CKEditor and it worked! But I need this plugin so please fix ASAP if possible... Thanks ;)
fournaise's picture
Joined: 27/02/2008
Posts: 17
Re: Problem with CKEditor changing my " marks to &quote
Hello,
To avoid CKEditor changing my special chars I've written a script :

When switching in source view :

CKEDITOR.instances.TEXT.on( 'mode', function(ev) {
      if ( ev.editor.mode == 'source' ) {
                        var str=ev.editor.getData();
         str=str.replace(/&amp;/g, "&").replace(/&gt;/g, ">").replace(/&lt;/g, "<").replace(/&quot;/g, "\"");
         ev.editor.textarea.setValue(str);
      }
});


When save edited document :

...
var html=CKEDITOR.instances.TEXT.getData()
html=html.replace(/&amp;/g, "&").replace(/&gt;/g, ">").replace(/&lt;/g, "<").replace(/&quot;/g, "\"");
...


HTH
garymgordon's picture
Joined: 06/11/2010
Posts: 11
Re: Problem with CKEditor changing my &quot; marks to &amp;quote
What file is being changed?
fournaise's picture
Joined: 27/02/2008
Posts: 17
Re: Problem with CKEditor changing my &quot; marks to &amp;quote
In the index file where you define the ckeditor instance.
garymgordon's picture
Joined: 06/11/2010
Posts: 11
Re: Problem with CKEditor changing my &quot; marks to &amp;quote
I'm using CKEditor in a Wordpress site. So, maybe what you added can't be applied to me.

What do you think?

Gary
honzahucin's picture
Joined: 22/11/2010
Posts: 2
Re: Problem with CKEditor changing my &quot; marks to &amp;quote
I have a similar problem, though not so serious. When typing a text in Czech using native letters as "á", "í" etc., CKEditor converts it into HTML entities (&aacute;, &iacute;...). So the text after this conversion is very hard to be read and its length is twice bigger, it is very annoying.
I looked into the patch meant above, I luckily understand it. Some changes in plugins.js may solve my problem. But is it completely sufficient to do it in _source/plugins/entities/plugin.js only?
Thank you for answer.
mikeg's picture
Joined: 20/11/2010
Posts: 5
Re: Problem with CKEditor changing my &quot; marks to &amp;quote
fournaise wrote:Hello,
To avoid CKEditor changing my special chars I've written a script :

Thanks that sounds good but I have no idea where to put that? Is it in two different files?? Will it affect my website in any bad way?
honzahucin's picture
Joined: 22/11/2010
Posts: 2
Re: Problem with CKEditor changing my &quot; marks to &amp;quote
Wow, I found it very simple at the end. Converting Latin character to entities can be avoided by the line
config.entities_latin = false;
added into configuration file (config.js)

This may be an useful link for somebody:
http://docs.cksource.com/ckeditor_api/s ... onfig.html
mikeg's picture
Joined: 20/11/2010
Posts: 5
Re: Problem with CKEditor changing my &quot; marks to &amp;quote
Great! I'll try that - hope it doesn't affect anything else. Thanks ;)